Začal vývoj ÚD pro Joomlu 2.5
Komponenta - Vývoj
Neděle, 12 Květen 2013 11:13
Po dlouhém odkádání jsem se konečně vrhnul na přeprogramování komponenty pro Joomlu 2.5. Bohužel nelze přepsat pouze několik řádků kódu, prakticky celou komponnetu programuju kompletně znovu. Nicméně jednotlivé algoritmy nemusím vymýšlet celé znovu, což dosti zrychluje práci. Nechci teď psát nějaký datum, kdy bude komponenta zcela hotova, protože jak všichni víme, termíny jsou od toho, aby se nedodržovaly :-). Záleží na tom, jak moc se bude Joomla "bránit" a také samozřejmě na mém volném čase. Zatím vám jako ochutnávku mohu nabídnout dva screeny z administrace.
A ještě dávám do pléna otázku: Byli byste ochotni za vývoj ÚD zaplatit a popř. kolik?

Hlavní strana administrace ÚD

Hlavní strana administrace ÚD

 

Nastavení ÚD

Nastavení ÚD

 

Komentáře  

 
# Diky!AH 2013-05-13 19:55
Díky, díky, díky!
Přispět bych byl ochoten-sice asi v řádech jednotek stokorun a ne tisíců (jinými slovy 5000 by bylo moc, ale tak do 1tis. by se dalo).
Ale je to nástřel...
Odpovědět | Odpovědět citací | Citovat
 
 
# DikyJiří Čtyroký 2013-05-30 09:51
Díky, to je výborná zpráva. Tahle komponenta je pro obce klíčová a unikátní a myslím, že je fér vývoj podpořit. Myslím, že pro Davli se příspěvek může pohybovat okolo 500-1500 Kč.
Moc se na komponentu těšíme, už migraci na 2.5 potřebujeme jako sůl.
Odpovědět | Odpovědět citací | Citovat
 
 
# DíkyMiloš 2013-06-02 18:33
Chtěl bych se zeptat jak jste na tom s úřední deskou a jestli nepotřebujete nějak pomoct klidně pomohu, potřeboval bych jí také na obecní stránku. Děkuji mnohokrát za brzkou odpověď
Odpovědět | Odpovědět citací | Citovat
 
 
# SuperMichal Gavlík 2013-06-02 23:19
Super, už se na novou verzi moc těším. :lol: Nedala by se vypustit nějaká betaverze ? ;-)
Odpovědět | Odpovědět citací | Citovat
 
 
# RE: SuperMiloš 2013-06-03 12:17
Taky bych byl rád za nějakou betaverzi nebo alespon o datum kdy by to mohlo být hotové, nebo alespon v jaké urovni je to vytvorene
Odpovědět | Odpovědět citací | Citovat
 
 
# SuperDaniel Krempaský 2013-06-07 15:32
No bolo by to super, ak by sa to podarilo čím skôr, veľmi to už očakávam a samozrejme, že som ochotný za UD aj zaplatiť, ak to bude v normálnych medziach, presne tak, ako písal AH - 5000,- by asi bolo moc, skôr sa prikláňam k tomu, čo písal vyššie Jiří Čtyroký : 500 - 1500,-
Odpovědět | Odpovědět citací | Citovat
 
 
# Nová verze pro J 2.5A. Havlíková 2013-08-22 03:09
Dobrý den, s úžasem až nyní zjišťuji, že jste vytvořil něco tak úžasného jako je vaše komponenta pro ÚD. Bohužel jsme byli z důvodu častých útoků hackerů nuceni přejít už teď na verzi 2.5, a tak zatím Vaši komponentu nemůžeme využít (což mě osobně moc mrzí). Jak to vypadá s novou verzí? Je v dohlednu? Pokud jde o platbu, nemohu hovořit za starostu, ale domnívám se, že platba v řádu stokorun by neměla být problém. A ještě se chci zeptat, zda by ve vaší komponentě ÚD šlo nastavit v archivu zobrazení příloh jen někomu (dle nastavení adminu). Děkuji
Odpovědět | Odpovědět citací | Citovat
 
 
# nová verzeStanda 2013-09-13 09:50
Dobrý den, nedočkavě čekáme na novou verzí uřední desky. Také jsme ochotní přispět na další vývoj. Jak to vidíte s dokončením?

Díky za odpověď.
S.Č.
Odpovědět | Odpovědět citací | Citovat
 
 
# Nutný upgrade na 2.5pavel 2013-09-17 09:47
Zdravím, upgrade na novou verzi joomla 2.5 je nevyhnutelný a budu ho muset do konce roku udělat. Joomla 1.5 je už hodně zastaralá a "děravá". Z mé strany není problém přispět a vidím to s cenovým rozpětím podobně jako ostatní kolem té pětistovky je to asi přijatelné. I když, je to opravdu klíčová komponenta pro obecní weby, takže otázkou zůstavá, jestli to nechat na přispění dobrovolném, nebo z toho udělat prostě komponentu placenou.
Odpovědět | Odpovědět citací | Citovat
 
 
# Moc prosím o odpověďAgáta Havlíková 2013-09-17 12:25
Ať to bude placené nebo dobrovolné. Opravdu nutně bych potřebovala vědět, jaký je stav věci, čili, zda na upgrade této komponenty čekat (neb by mohl např. do konce roku být) nebo hledat jinde. Ony placené komponenty by k mání byly jinde, ale stejně jako asi i jiní, my máme poměrně omezený rozpočet a obecní stránky jsme dělali v Joomle právě proto, že je to bez nákladů. Tedy mám otázku, jaý je stav nyní - stále platí, že konec je v nedohlednu a možná verze 2.5 ani nebude? MOC prosím o odpověď...
Odpovědět | Odpovědět citací | Citovat
 
 
# RE: Moc prosím o odpověďAdministrator 2013-09-17 16:00
Bohužel přes léto jsem se k vývoji ÚD vůbec nedostal, ale do konce září bych rád zveřejnil aspoň nějakou beta verzi, která by třeba zatím byla bez možnosti editace ve frontendu.
Odpovědět | Odpovědět citací | Citovat
 
 
# RE: RE: Moc prosím o odpověďAgáta Havlíková 2013-09-17 16:46
Dkuju,. Toiužebně očekávám...
Odpovědět | Odpovědět citací | Citovat
 
 
# RE: RE: Moc prosím o odpověďMichal Gavlík 2013-09-17 16:49
Jednoznačně palec nahoru :lol:
Odpovědět | Odpovědět citací | Citovat
 
 
# Testovací verze ÚD pro J2.5Administrator 2013-10-10 23:28
Nyní je možné stáhnout, nainstalovat a otestovat administrační rozhraní ÚD pro J2.5. Více informací uredni-deska.g6.cz/.../....
Odpovědět | Odpovědět citací | Citovat
 
 
# RE: Začal vývoj ÚD pro Joomlu 2.5Standa 2013-09-17 12:36
Pokud by vám to usnadnilo práci, není nutně potřeba aby nová verze uměla migraci z původní verze.
Díky.
S.Č.
Odpovědět | Odpovědět citací | Citovat
 
 
# Komponenta pro Joomlu 3.1Martin Jurů 2013-09-23 11:40
Přikláním se spíše k tomu, aby komponenta byla vydaná i pro Joomlu 3.1 (3.5), která bude mít podporu až do roku 2015
Odpovědět | Odpovědět citací | Citovat
 
 
# RE: Komponenta pro Joomlu 3.1Michal Gavlík 2013-09-23 11:44
nemichal bych 3.1 a 3.5 - prvni je STS, druha LTS...
Odpovědět | Odpovědět citací | Citovat
 
 
# STS a LTSMartin Jurů 2013-09-23 12:58
Já to nemíchám, pouze poukazuji na to, že pokud by vývoj nebyl pro STS 3.1 (nebo by se nestihnul nebo vůbec nezačal), tak preferuji LTS Joomlu 3.5, která bude mít podporu do roku 2015 (vychází 2014-03). Jinak nevím, jaký je autor této komponenty zdatný programátor, ale existují komponenty, které jsou napsány pro J3.1 a zároveň fungují i pro 2.5, takto bych si to například představoval. Rozhodnutí je ovšem na něm.
Odpovědět | Odpovědět citací | Citovat
 
 
# RE: STS a LTSAdministrator 2013-09-23 16:34
Zatím jsem nikde neslyšel, že by rozšíření z J2.5 nemělo fungovat i v J3.5. Vydávat rozšíření pro J3.1 my přijde zbytečné (ale netvrdím, že verze pro J2.5 nebude fungovat i v J3.1).
Odpovědět | Odpovědět citací | Citovat
 
 
# Tichopavel 2014-04-17 08:46
Zdravím, slouho tady je okolo toho ticho. Jak to prosím vypadá s vývojem?
Odpovědět | Odpovědět citací | Citovat